Browse Source

if PHP_VERSION check fails, show current version

Andrew Dolgov 6 months ago
parent
commit
c4869cd573
3 changed files with 3 additions and 3 deletions
  1. 1 1
      include/sanity_check.php
  2. 1 1
      index.php
  3. 1 1
      install/index.php

+ 1 - 1
include/sanity_check.php

@@ -47,7 +47,7 @@
 			}
 
 			if (version_compare(PHP_VERSION, '5.6.0', '<')) {
-				array_push($errors, "PHP version 5.6.0 or newer required.");
+				array_push($errors, "PHP version 5.6.0 or newer required. You're using " . PHP_VERSION . ".");
 			}
 
 			if (CONFIG_VERSION != EXPECTED_CONFIG_VERSION) {

+ 1 - 1
index.php

@@ -12,7 +12,7 @@
 	// we need a separate check here because functions.php might get parsed
 	// incorrectly before 5.3 because of :: syntax.
 	if (version_compare(PHP_VERSION, '5.6.0', '<')) {
-		print "<b>Fatal Error</b>: PHP version 5.6.0 or newer required.\n";
+		print "<b>Fatal Error</b>: PHP version 5.6.0 or newer required. You're using " . PHP_VERSION . ".\n";
 		exit;
 	}
 

+ 1 - 1
install/index.php

@@ -39,7 +39,7 @@
 		$errors = array();
 
 		if (version_compare(PHP_VERSION, '5.6.0', '<')) {
-			array_push($errors, "PHP version 5.6.0 or newer required.");
+			array_push($errors, "PHP version 5.6.0 or newer required. You're using " . PHP_VERSION . ".");
 		}
 
 		if (!function_exists("curl_init") && !ini_get("allow_url_fopen")) {