Browse Source

sanity_check: enforce minimum php version (5.4)

Andrew Dolgov 4 years ago
parent
commit
bfd902bbcc
2 changed files with 4 additions and 4 deletions
  1. 2 2
      include/sanity_check.php
  2. 2 2
      install/index.php

+ 2 - 2
include/sanity_check.php

@@ -43,8 +43,8 @@
 				array_push($errors, "Please don't run this script as root.");
 			}
 
-			if (version_compare(PHP_VERSION, '5.3.0', '<')) {
-				array_push($errors, "PHP version 5.3.0 or newer required.");
+			if (version_compare(PHP_VERSION, '5.4.0', '<')) {
+				array_push($errors, "PHP version 5.4.0 or newer required.");
 			}
 
 			if (CONFIG_VERSION != EXPECTED_CONFIG_VERSION) {

+ 2 - 2
install/index.php

@@ -39,8 +39,8 @@
 	function sanity_check($db_type) {
 		$errors = array();
 
-		if (version_compare(PHP_VERSION, '5.3.0', '<')) {
-			array_push($errors, "PHP version 5.3.0 or newer required.");
+		if (version_compare(PHP_VERSION, '5.4.0', '<')) {
+			array_push($errors, "PHP version 5.4.0 or newer required.");
 		}
 
 		if (!function_exists("curl_init") && !ini_get("allow_url_fopen")) {